首页 > 云计算 > 微软云不能安装GCC和GCC-C++的解决方法。
2013
06-26

微软云不能安装GCC和GCC-C++的解决方法。

报错如下:

Error: Package: glibc-headers-2.12-1.80.el6_3.7.x86_64 (updates)
           Requires: kernel-headers
Error: Package: glibc-headers-2.12-1.80.el6_3.7.x86_64 (updates)

解决办法:

vi /etc/yum.conf

注释掉exclude=kernel*

[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum
distroverpkg=centos-release
http_caching=packages
exclude=kernel*

exclude=kernel* 加入#号注释掉 #exclude=kernel*
;wq即可

重新执行

yum install gcc gcc-c++

留下一个回复

你的email不会被公开。